Xero not syncing

Incident Report for Dubsado

Resolved

This incident has been resolved and all syncing should return to normal.

If you’re still experiencing any issues, please don’t hesitate to reach out to our team at hello@dubsado.com
Posted Jul 28, 2026 - 16:03 PDT

Investigating

We’ve confirmed an issue with the Xero integration in Dubsado 3.0. Data has not been syncing to Xero since July 25 at 10:30 AM Pacific.

Our engineering team is digging into the cause now and will roll out a fix as soon as they have one. There’s nothing you need to do on your end. We’ll post updates here as we learn more, and we’ll let you know what happens with data from the affected window once we know.
Posted Jul 28, 2026 - 15:55 PDT